August 8, 2002

I’ve actually made some headway in releasing Blog 6.1 :-) I was able to find and fix the bug with customized code snippets not staying for long on the toolbar but disappearing after a couple of restarts of Blog – of course, I just thought of another possible scenario! What if there was no icon defined for a custom snippet? Does the caption display or does it become a blank button? I guess I’d better test that today too!

Tyran pointed out a couple of bugs that needed to be fixed as well. Tyran mentioned that Blog gives an AV (Access Violation) each time he starts the latest version – a beta build of 6.1 – and I realized that to do an upgrade to 6.1, you’ll need to delete your Blog.cfg file and lose all toolbar customizations! Sorry :-( In case, I forget to mention this in the docs, remember to delete the Blog.cfg file if you are upgrading :p Tyran also mentioned that you can now run multiple instances of Blog without any problems and I realized that I’d changed the component which makes sure that only one instance of Blog is running (actually, I’d made the changes to be used in Scope …) and that I’d never integrated the changes into Blog. Now it works fine again – though not quite transparently since you can see the second instance start up and then disappear. Oh well, eh? :p

Incidentally, I notice that Delphi 7.0 is going to be released soon. I’d realized that Delphi 7.0 should be around the corner since JBuilder 7.0 is already out (and I’m using it :p) but I couldn’t find any reference to JBuilder 7.0 on Borland’s site and so thought maybe it wouldn’t be for a while yet. Today, I read on the Addict (the spell-checker component I use …) newsgroup that they are expecting Delphi 7.0 soon. Wonder what the new changes are? I guess, I’ll upgrade anyway – if I can get my hands on Delphi 7.0 that is :p – but I always like to know what’s new. I hope that they’ve fixed the type library importing for the HTML library under IE 6.0 since I can’t do any work on Scope till they do. It was supposedly fixed with Delphi 6.0 SP2 but it still doesn’t work for me :-( Maybe it’s because I’m running XP? I don’t know …

Be Sociable, Share!
Tags: General
Posted by Fahim at 6:32 am   Comments (0)